Undefined Symbol Errors When Upgrading from a version to another

 

This morning, a customer reported the following error while printing their checks remittances:

Undefined Symbol F01343D00789 Sequence Num

image

Last week I have upgraded this customer from Microsoft Dynamics GP Version 10.0 with Service Pack 4 to Microsoft Dynamics Version 2010 with Service Pack 1, when the customer sent me the package, I found that the package they sent is mapped to a table called “PM_Payment_WORK” while the original reports is mapped to “pmRemittanceTemp” then I figured out the reason behind this, this was due to the enhancements applied to this feature in GP 2010.

To resolve this, the hard way of doing this is by re-implementing the customizations on the original report. However there is always a workaround!

Below the steps I followed:

  1. I exported the report to a package file.
  2. I opened it using Notepad.
  3. Pressed CTRL+H to find and replaced PM_Payment_WORK to pmRemittanceTemp.
  4. Saved and imported the report.
  5. Regenerated the report and found 2 missing fields, replaced the missing fields with an alternative from the new table and it worked!

Enjoy fixing your reports without re-implementing your customizations!

Regards,

Mohammad R. Daoud MVP – MCT
MCP, MCBMSP, MCTS, MCBMSS
+962 – 79 – 999 65 85
me@mohdaoud.com
www.mohdaoud.com

Advertisements

About Mohammad R. Daoud
Mohammad R. Daoud has been working as a Microsoft Dynamics GP consultant since 2004. His career path started with version 7.5; he studied every single tip of the application technicalities and did allot of successful implementations that includes functional consultations, analysis, and custom development projects. He holds a graduate degree in Computer Science and currently he is pursuing MBA degree in Accounting. In January 2007 he was nominated to the Microsoft Most Valuable Professional (MVP) certificate and was certified in April 2008 due to his online contributions in the Dynamics Community (Dynamics GP Newsgroups, Forums, User Groups and his blog: http://mohdaoud.blogspot.com). Worth to mention that he was also listed as one of the Microsoft Dynamics Top 100 Most Influential People in 2009 by DynamicsWorld. And more... • Demonstrated Passion for MS Products through participating in beta testing for some product versions, an effective member of Microsoft Connect. • Talented in securing strong high quality relationships with premier customers, partners and sales teams passionately and profitably. • Dedicated to meeting the expectations and requirements of internal and/or external customers • Problem Solver – Uses systematic approach to uncover true problem(s) and practical solution and can marshal resources to solve problem! • Proven record of effective account management, including Account Planning, Opportunity Management, and Business Management Excellence and working as part of a larger virtual team • Successful in delivering high quality technical engagements in the enterprise Dynamics GP implementations area according to customer requirements. • Dedicated, Committed, Self Motivated, Creative and highly focused with excellent communication, Negotiation, presentation, Active Listening and Objection Handling skills. • Experienced in Profitable researches and studies including white papers and technical presentations.

7 Responses to Undefined Symbol Errors When Upgrading from a version to another

  1. Anonymous says:

    Thanks for post. I had the same problem and used your technique to solve it without duplicating the mods. I also noticed that the key # for table needs to be changed after re-importing the edited report; it should be key #3.

  2. Priyan says:

    Great Post. Simple and to the point. Was Invaluable.

  3. Anonymous says:

    Thanks! I had the same problem and this took care of it.

  4. Anonymous says:

    I also had this issue….and these fixes worked on my workstation…but on my client it states a new error SYMBOL ALREADY DEFINED…ANY IDEAS?

  5. Anonymous says:

    Thank you very much. Saved me a whole lot of trouble.Saras

  6. Melvin says:

    After making the changes suggested. I got an "inconsistent table hierarchy" error. I went to report writer and added a relationship for table pmRemittanceTemp and Credit Master File. Now when I process my remittance, I get an error "Undefinded Symbol Voucher Number". I believe this has to do with the fact I chaged the table names to pmRemittanceTemp on the report. Did anyone run into this issue? Please advise.

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

%d bloggers like this: